11/28/2021

卸载Win11小组件

 管理员权限运行CMD

winget uninstall MicrosoftWindows.Client.WebExperience_cw5n1h2txyewy

5/22/2021

macvlan模式的容器与宿主机通信

https://notesail.com/posts/macvlan-host.html



 # 以下操作都在宿主机上运行,新增一个叫mynet(不要和容器的macvlan重名)的macvlan接口

ip link add mynet link eth0 type macvlan mode bridge

# 为该接口分配ip,并启用

ip addr add 192.168.0.10 dev mynet

ip link set mynet up

# 修改路由,使宿主机到192.168.0.100的通信全部经由mynet进行

ip route add 192.168.0.100 dev mynet

10/24/2020

复制文件显示进度

 rsync -ah --progress source-file destination-file

  sending incremental file list

  source-file

          621.22M  57%  283.86MB/s    0:00:01

显示进度时,这将保留文件的权限/所有权。

10/23/2020

关于esxi6.7设置直通显卡后开机卡dma_mapper_iommu loaded successfully的解决方法

 from https://blog.csdn.net/ID_Rin/article/details/105341206


前提

           设备安装了esxi6.7包括U1,U2,U3版本,设置显卡直通后卡开机界面dma_mapper_iommu loaded successfully

           等待3分钟,ping 设置的ip地址依然超时,不可以登录的问题!

设备:一台win电脑,一个U盘,

软件:UltraISO安装包  以及  ubuntu18.04.ISO镜像

操作

1.  win电脑下载安装UltraISO后,把Ubuntu的iso刻录到U盘,iso建议为18.04版本;

2.  U盘插入设备,开机启动电脑选择U盘启动;

3.  打开Terminal 

4.  输入:

      输入lspci 快速查找

      我的是NVIDIA 的GM107 GTX960 id:0000:01:00.0                  #vendor:10de  #device :139b

      英特尔核显的pcie的id是00:02.0                                                  #vendor:8086  #device :416

 

      sudo parted -l  #查看硬盘

      sudo mount /dev/sda5   /mnt   #挂载

      ls /mnt/

      cp /mnt/state.tgz ~/

      cd ~

      tar xvf state.tgz

      tar xvf local.tgz

      cd etc/vmware/

      nano esx.conf

      找到  /device/<PCI_ID>/owner = "passthru"   #PCI_ID就是上面找到的0000:01:00.0   和  0000:00:02.0 

      使用 vmkernel  代替 passthru

 

      按ctrl+X 退出 按Y确认回车  不放心的可以再nano一次进去看看

      cd ~

      tar czf local.tgz etc/

      tar czf state.tgz local.tgz

      sudo cp state.tgz /mnt/

      重启电脑 拔U盘

大功告成!

7/29/2020

CHM文件无法从网络共享位置上直接打开

症状:
无法从网上邻居的共享位置或映射的网络驱动器上直接打开.chm文件。
从网络共享位置上打开.chm文件,显示为空白或运行不正常,而文件本身是正常的,复制到本地打开就可正常显示,而在网络邻居上则不能。
原因:
Microsoft 公司发布的HTML帮助的安全补丁,将HTML的安全设置提高,默认将禁止非本机HTML帮助文件中控件的访问,以保护计算机安全。
对比:
安装HTML帮助补丁后,在默认设置下,从网络共享上查看.chm帮助文件,显示为空白
在注册表中设置允许从本地局域网上访问.chm帮助文件后,显示正常
解决方法:
①将文件拷贝到本地
②直接运行下面的命令:
reg add HKLM\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions /v MaxAllowedZone /t REG_DWORD /d 3 /f
附撤消修改(恢复默认)方法,删除相应注册表键值或直接运行下面命令:
reg delete HKLM\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions /f

link http://www.plge.com.cn/archives/789

设置Win10开机自动登录进桌面

win+R运行netplwiz
去掉“要使用本计算机,用户必须输入用户名和密码”复选框后按确定

12/09/2019

修复损坏的VMDK文件

先打开VMware的SSH,检查一下对应的vmdk文件:
vmkfstools -x check /path/to/your/machine.vmdk(修改成自己的路径及文件名)
如果提示“Disk needs repair.”
运行修复命令:
vmkfstools -x repair /path/to/your/machine.vmdk(修改成自己的路径及文件名)
修复速度很快,完成后后提示“Disk was successfully repaired.”
这时就可以启动虚拟机了

5/18/2019

RouterOS 重新拨号后,从接口获得新ip并更新规则

备忘,
范例
1
2
3
4
5
6
7
:global ipaddr [/ip address get [/ip address find interface=pppoe4plex] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
:global oldip [/ip firewall nat get [/ip firewall nat find comment="plexdstnat"] dst-address]
:if ($ipaddr != $oldip) do={
:log info [/ip firewall nat set [/ip firewall nat find comment="plexdstnat"] dst-address=$ipaddr]
:log info [/ip firewall nat set [/ip firewall nat find comment="plexsrcnat"] to-addresses=$ipaddr]
}

RouterOS Cloudflare DDNS Script 脚本

also here

备忘

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
################# CloudFlare variables #################
:local CFDebug "true"
:global WANInterface "pppoe4plex"

:local CFdomain "*****.lingbo.me"
:local CFzone "lingbo.me"

:local CFrecordType "A"
:local CFemail "****************@gmail.com"
:local CFtkn "bc24e143b3840****************9e13a5"

:local CFzoneid "a926a****************accb8"
:local CFid "661c43a****************95994087"

#########################################################################
######################## DO NOT EDIT BELOW ############################
#########################################################################

################# Internal variables #################
:local resolvedIP ""
:global WANip ""

################# Resolve and set IP-variables #################
:local currentIP [/ip address get [/ip address find interface=$WANInterface ] address];
:set WANip [:pick $currentIP 0 [:find $currentIP "/"]];
:set resolvedIP [:resolve $CFdomain];

################# Build CF API Url (v4) #################
:local CFurl "https://api.cloudflare.com/client/v4/zones/"
:set CFurl ($CFurl . "$CFzoneid/dns_records/$CFid");

######## Write debug info to log #################
:if ($CFDebug = "true") do={
:log info ("CF: hostname = $CFdomain")
:log info ("CF: resolvedIP = $resolvedIP")
:log info ("CF: currentIP = $currentIP")
:log info ("CF: WANip = $WANip")
:log info ("CF: CFurl = $CFurl&amp;content=$WANip")
};

######## Compare and update CF if necessary #####
:if ($resolvedIP != $WANip) do={
:log info ("CF: Updating CF, setting $CFDomain = $WANip")
/tool fetch http-method=put mode=https url="$CFurl" http-header-field="X-Auth-Email:$CFemail,X-Auth-Key:$CFtkn,content-type:application/json" output=none http-data="{"type":"$CFrecordType","name":"$CFdomain","content":"$WANip"}"
/ip dns cache flush
} else={
:log info "CF: No Update Needed!"
}

2/16/2019

copy files on freenas

1
 find /mnt/vol1/ptdataset/ptuser/download/ -name '*.mp4' -print0 | xargs -0 -I% cp -nrsv % /mnt/vol1/lnk/

拷贝整个目录并创建硬链接

1
cp -al <origdir> <newdir>

卸载Win11小组件

  管理员权限运行CMD winget uninstall MicrosoftWindows.Client.WebExperience_cw5n1h2txyewy